1
0
python-pytest-dependency/python-pytest-dependency.spec
Dirk Mueller b93bcde296 - update to 0.6.0:
* #39, #41, #59: Review documentation
  * Drop support for Python 2.
  * #40: add logging.
  * #50, #51: test suite incompatibility with pytest 6.2.0.
  * #58: declare the type of automark_dependency ini-option
    correctly as bool.
  * #75: review build tool chain.
- drop pytest6.2.patch (upstream)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:pytest/python-pytest-dependency?expand=0&rev=8
2024-01-09 22:08:51 +00:00

61 lines
1.8 KiB
RPMSpec

#
# spec file for package python-pytest-dependency
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-pytest-dependency
Version: 0.6.0
Release: 0
Summary: Manage dependencies of tests
License: Apache-2.0
URL: https://github.com/RKrahl/pytest-dependency
Source: https://files.pythonhosted.org/packages/source/p/pytest-dependency/pytest-dependency-%{version}.tar.gz
BuildRequires: %{python_module setuptools}
BuildRequires: python-rpm-macros
# SECTION test requirements
BuildRequires: %{python_module pytest >= 3.6.0}
# /SECTION
BuildRequires: fdupes
Requires: python-pytest >= 3.6.0
BuildArch: noarch
%python_subpackages
%description
This pytest plugin manages dependencies of tests. It allows to mark
some tests as dependent from other tests. These tests will then be
skipped if any of the dependencies did fail or has been skipped.
%prep
%setup -q -n pytest-dependency-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc README.rst
%license LICENSE.txt
%{python_sitelib}/*
%changelog