SHA256
1
0
forked from pool/snpguest
snpguest/snpguest.spec
Caleb Crane 03af8783c3 - Update to version 0.7.1:
* Fixing clippy version bug
  * Fixing case sensitivity bug
  * Reflect 0.7.0 update in Cargo.lock
  * Update to 0.7.0
  * README: Clarify fetch ca documentation
  * Upgrade MSRV to 1.80
  * Upgrade MSRV to 1.74
  * Remove strict versioning on clap dependency
  * Update the README.md: fix the uncomplete description of the fetch ca command.
  * Added build dependencies for openSUSE (#64)
  * bumping version
  * Adding preattestation functionality to snpguest (#63)
  * rust: Patching for latest rust update
  * Update to 0.5.1
  * Update to 0.5.0
  * fix: remove subcommand trait on ok command
  * clap-migration: Moving from StructOpt to Clap
  * Fix the context message for failing to open SEV firmware.
  * Adding SNPHOST workflows to SNPGUEST
  * Additional Features
  * Adding snpguest ok
  * vlek: Missing some logic during verify for vlek.
  * Bump mio from 0.8.10 to 0.8.11
- Service: Remove deprecated cargo_config and cargo_audit services, both
    are now handled by the cargo_vendor service
- Spec: Remove pre-release tag from version string
- Fix build failure after update to Rust 1.80 (bsc#1228972)

OBS-URL: https://build.opensuse.org/package/show/Virtualization/snpguest?expand=0&rev=6
2024-09-13 03:06:15 +00:00

55 lines
1.6 KiB
RPMSpec

#
# spec file for package snpguest
#
# Copyright (c) 2024 SUSE LLC
# Copyright (C) 2023 VirTEE
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: snpguest
Version: 0.7.1
Release: 0
Summary: A Rust command-line tool for interacting with the AMD Secure Processor
License: Apache-2.0
Group: Productivity/Security
URL: https://github.com/virtee/snpguest
Source0: %{name}-%{version}.tar.gz
Source1: vendor.tar.gz
BuildRequires: cargo-packaging
ExclusiveArch: x86_64
%description
snpguest is a command line utility for interacting with the AMD Secure Encrypted Virtualization - Secure Nested Paging (SEV-SNP) guest environment (via the /dev/sev-guest device).
%prep
# The number passed to -a (a stands for "after") should be equivalent to the Source tag number
# of the vendor tarball, 1 in this case (from Source1).
%autosetup -a1
%build
%{cargo_build}
%install
%{cargo_install}
%check
%{cargo_test}
%files
%license LICENSE
%doc README.md
%{_bindir}/%{name}
%changelog