SHA256
1
0
forked from pool/testssl.sh
testssl.sh/testssl.sh.spec
Dirk Mueller e0c16f8f32 - Update to version 3.0.9
* Fix bash 5 issue when encountering a short server key extension
  * Fix HTML issue when using bash 5
  * CAA DNS records are now not being queried when nodns is set
  * MongoDB identification fix
  * Sanity check when user has broken umask to avoid runtime errors
  * Fix for newer grep versions
  * Address weird globbing in bash 3.0
  * Fix regexp in STARTTLS detection
  * Secure renegotiation fix: SNI
  * Ensure control chars from HTTP header don't end up in html,csv
    or json
  * Add sha1WithRSA to sha1WithRSAEncryption for certificates
  * Fix potential infinite loop in run_pfs()

OBS-URL: https://build.opensuse.org/package/show/network:utilities/testssl.sh?expand=0&rev=21
2024-07-25 11:46:35 +00:00

66 lines
2.1 KiB
RPMSpec

#
# spec file for package testssl.sh
#
# Copyright (c) 2024 SUSE LLC
# Copyright (c) 2018 Matthias Fehring <buschmann23@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define _data_dir_name testssl-sh
Name: testssl.sh
Version: 3.0.9
Release: 0
Summary: Testing TLS/SSL Encryption Anywhere On Any Port
License: GPL-2.0-or-later
Group: Productivity/Networking/Security
URL: https://testssl.sh
Source0: https://github.com/drwetter/%{name}/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source1: %{name}-rpmlintrc
Patch0: testssl.sh-2.9.95-set-install-dir.patch
Requires: bash >= 3.2
Requires: bind-utils
Requires: openssl
BuildArch: noarch
%description
testssl.sh is a free command line tool which checks a server's service on
any port for the support of TLS/SSL ciphers, protocols as well as some
cryptographic flaws.
%prep
%autosetup -p1
%if 0%{?suse_version} > 1500
sed -i 's|#!/usr/bin/env bash|#!/usr/bin/bash|g' testssl.sh
%else
# in Leap 15.x, it's still /bin/bash
sed -i 's|#!/usr/bin/env bash|#!/bin/bash|g' testssl.sh
%endif
%build
%install
install -D -m 0644 -t %{buildroot}/%{_datadir}/%{_data_dir_name}/etc etc/*
install -D -m 0755 -t %{buildroot}/%{_bindir} %{name}
install -D -m 0644 -T doc/testssl.1 %{buildroot}/%{_mandir}/man1/%{name}.1
%files
%license LICENSE
%doc CHANGELOG.md CREDITS.md Readme.md
%{_bindir}/%{name}
%{_datadir}/%{_data_dir_name}
%{_mandir}/man1/%{name}.1%{ext_man}
%changelog