SHA256
1
0
forked from pool/volk
volk/volk.spec
Martin Pluskal f4e3120413 Accepting request 1151972 from home:wkazubski:test:science
- Update to version 3.1.2
  Documentation improvements, and automatically generate and publish
  * docs: Add VOLK doc build to CI
  * docs: Add upload to GitHub actions
  * cpu_features: Update hints in README
  Remove sse2neon with a native NEON implementation
  * Replace sse2neon with native NEON
  * Remove loop unrolling
  * Simplify Spiral-generated code
  Improve CI pipeline with new runner
  * flyci: Test CI service with M2 instance
  * actions: Update GH Actions checkout
  Auto-format CMake files
  * cmake: Add .cmake-format.py
  * cmake: Apply .cmake-format.py
  Release script fixes
  * scripts/release: fix multi-concatenation of submodule tars
  * shellcheck fixes
  * bash negative exit codes are not portable, let's be positive
- Update to version 3.1.1
  CI fixes
  * Allow for rounding error in float-to-int conversions
  * Allow for rounding error in volk_32fc_s32f_magnitude_16i
  * Allow for rounding error in float-to-int interleave
  * Add missing volk_16_byteswap_u_orc to puppet
  * Fix 64-bit integer testing
  * Build and test neonv7 protokernels on armv7
  kernels
  * Remove broken sse32 kernels
  * Fix flaky fm_detect test
  * Fix flaky mod_range test
  * Remove unnecessary volatiles from volk_32fc_s32f_magnitude_16i
  * Remove SSE protokernels written in assembly
  * Remove inline assembler from volk_32fc_convert_16ic_neon
  * Use bit shifts in generic and byte_shuffle reverse
  * Remove disabled SSE4.1 dot product
  * Fix conv_k7_r2 kernel and puppet
  * Remove unused argument from renormalize
  * Align types in ORC function signatures
  * Uncomment AVX2 implementation
  * Renormalize in every iteration on AVX2
  * Remove extraneous permutations
  * Compute the minimum over both register lanes
  * volk_32fc_s32f_atan2_32f: Add NaN tests for avx2 and avx2fma
    code
  fixes
  * Express version information in decimal
  * Remove __VOLK_VOLATILE
  * Remove references to simdmath library
  * cmake: Switch to GNUInstallDirs
  * fprintf: Remove fprintf statements from volk_malloc
  * release: Prepare release with updated files
  * Get the sse2neon.h file to a git submodule to avoid random
    copies.

OBS-URL: https://build.opensuse.org/request/show/1151972
OBS-URL: https://build.opensuse.org/package/show/hardware:sdr/volk?expand=0&rev=25
2024-02-27 07:39:09 +00:00

111 lines
3.1 KiB
RPMSpec

#
# spec file for package volk
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global sonum 3
%global soname 3_1
Name: volk
Version: 3.1.2
Release: 0
Summary: Vector-Optimized Library of Kernels
License: LGPL-3.0-or-later
Group: Development/Libraries/C and C++
URL: https://libvolk.org/
Source: https://github.com/gnuradio/volk/releases/download/v%{version}/%{name}-%{version}.tar.xz
Source98: https://github.com/gnuradio/volk/releases/download/v%{version}/%{name}-%{version}.tar.xz.asc#/%{name}-%{version}.tar.xz.asc
Source99: volk.keyring
BuildRequires: cmake
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: libboost_filesystem-devel
BuildRequires: libboost_system-devel
BuildRequires: orc
BuildRequires: python-rpm-macros
BuildRequires: python3-Mako
Provides: bundled(cpu_features) = 0.6.0
%description
VOLK is a library of vector-optimized kernels. It is a subproject
of GNU Radio, but can also be used standalone.
%package devel
Summary: Development files for VOLK
# Formerly part of gnuradio 3.7.x.y
Group: Development/Libraries/C and C++
Requires: libvolk%{soname} = %{version}
Recommends: volk_modtool
Conflicts: gnuradio-devel < 3.8.0.0
Provides: gnuradio-devel:%{_libdir}/pkgconfig/volk.pc
%description devel
This package provides the the development files for VOLK.
%package -n libvolk%{soname}
Summary: Vector-Optimized Library of Kernels
Group: System/Libraries
Recommends: volk
%description -n libvolk%{soname}
This package provides the VOLK shared library.
%package -n volk_modtool
Summary: VOLK kernel creation utility
Group: Development/Tools/Other
%description -n volk_modtool
This package provides volk_modtool, used for creating new
VOLK kernels.
%prep
%autosetup
%build
%cmake
%cmake_build
%install
%cmake_install
chmod -x %{buildroot}%{python3_sitearch}/volk_modtool/*py
sed -i -e '1 { \@.*/bin/env.*python.*@ d }' %{buildroot}%{python3_sitearch}/volk_modtool/*py
%fdupes %{buildroot}/%{_prefix}
%post -n libvolk%{soname} -p /sbin/ldconfig
%postun -n libvolk%{soname} -p /sbin/ldconfig
%files
%license COPYING
%doc docs/CHANGELOG.md README.md
%{_bindir}/volk_profile
%files devel
%{_bindir}/volk-config-info
%{_includedir}/volk
%{_libdir}/cmake/volk
%{_libdir}/libvolk.so
%{_libdir}/pkgconfig/volk.pc
%files -n libvolk%{soname}
%{_libdir}/libvolk.so.%{sonum}*
%files -n volk_modtool
%doc python/volk_modtool/README.md
%{_bindir}/volk_modtool
%{python3_sitearch}/volk_modtool
%changelog