SHA256
1
0
forked from pool/wp-cli
wp-cli/wp-cli.spec
Yunhe Guo 185c43dab5 Accepting request 1165993 from home:amanzini:branches:server:php:applications
- Update to version 2.10.0
  * Fix PHP deprecation warnings [#5897]
  * Only use --skip-column-statistics flag when available [#5895]
  * Handle unparseable tags gracefully [#5894]
  * WpOrgApi: allow specifying fields request param [#5893]
  * Remove unneeded compatibility shim [#5885]
  * Suggest 'network meta' intead of 'network option' [#5879]
  * Updated Doc Block for Admin.php [#5877]
  * Admin Context: Fix PHP fatals when admin.php has CRLF line endings [#5875]
  * Standard completion of current option [#5873]
  * Add WP_CLI\Utils\has_stdin() function [#5872]
  * Add verbosity level and quiet flag in ssh command based on debug flag [#5869]
  * Revert "Move RecursiveDataStructureTraverser to wp-cli/wp-cli package" [#5866]
  * Add missing required arguments when using --prompt [#5865]
  * Move RecursiveDataStructureTraverser to wp-cli/wp-cli package [#5864]
  * Add docker compose command support in SSH command generation [#5863]
  * Add missing documentation for $data attribute in http_request() [#5861]
  * Updated Inline PHP Documentation [#5853]
- Update to version 2.9.0
  * Add debugging output for @when command registration [#5841]
  * Fix --skip-themes for WordPress 6.4 [#5840]
  * Update phpcs.xml to match new WPCS rules [#5836]
  * Update to WPCS v3 [#5834]
  * Respect alias --path= in IncludeRequestsAutoloader [#5830]
  * Update type hint of $callable parameter in add_command() method [#5828]
  * Display a custom error message when themes/functions.php fatals [#5817]
  * Fix PHP 8.1 deprecation: ReturnTypeWillChange [#5807]
  * Add support for the proxyjump key [#5805]
  * Mention updating the homepage in the release process [#5802]

OBS-URL: https://build.opensuse.org/request/show/1165993
OBS-URL: https://build.opensuse.org/package/show/server:php:applications/wp-cli?expand=0&rev=12
2024-04-13 09:12:12 +00:00

57 lines
1.7 KiB
RPMSpec

#
# spec file for package wp-cli
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: wp-cli
Version: 2.10.0
Release: 0
Summary: WordPress command-line interface
License: MIT
URL: https://wp-cli.org/
Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.phar
Source1: https://raw.githubusercontent.com/%{name}/%{name}/v%{version}/utils/wp-completion.bash
Requires: php >= 5.6
Requires: php-json
Requires: php-openssl
Requires: php-phar
Requires: php-zip
BuildArch: noarch
%description
WP-CLI is the command-line interface for WordPress. You can update plugins,
configure multisite installations and much more, without using a web browser.
%prep
%autosetup -c -T
%build
%install
mkdir -p %{buildroot}%{_bindir}
install -m 0755 %{SOURCE0} %{buildroot}%{_bindir}/wp
mkdir -p %{buildroot}%{_sysconfdir}/profile.d
install -m 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d
%check
%files
%defattr(-,root,root,0755)
%{_bindir}/wp
%config %{_sysconfdir}/profile.d/wp-completion.bash
%changelog