SHA256
3
0
forked from pool/automake
automake/automake.spec
Valentin Lefebvre 6b9cb9cb09 - update to 1.17
- AM_PATH_PYTHON will, after checking "python", prefer any Python 3
    version (latest versions checked first) over any Python 2
    version. If a specific version of Python 2 is still needed, the
    $PYTHON variable should be set beforehand.
  - AM_PATH_PYTHON will also search for Python versions 3.20 through 3.10.
    It previously searched for 3.9 through 3.0.
  - RANLIB may be overridden on a per-target basis.
  - AM_TEXI2FLAGS may be defined to pass extra flags to TEXI2DVI & TEXI2PDF.
  - New option "posix" to emit the special target .POSIX for make.
  - Systems with non-POSIX "rm -f" behavior are now supported, and the
    prior intent to drop support for them has been reversed.
    The ACCEPT_INFERIOR_RM_PROGRAM setting no longer exists.
  - Variables using escaped \# will trigger portability warnings, but be
    retained when appended.  GNU Make & BSD Makes are known to support it.
  - GNU Make's default pattern rules are disabled, for speed and debugging.
    (.SUFFIXES was already cleared.)
  - For Texinfo documents, if a .texi.in file exists, but no .texi, the
    .texi.in will be read. Texinfo source files need not be present at
    all, and if present, need not contain @setfilename. Then the file name
    as given in the Makefile.am will be used.  If @setfilename is present,
    it should be the basename of the Texinfo file, extended with .info.
  - aclocal has a new option --aclocal-path to override $ACLOCAL_PATH.
  - The missing script also supports autoreconf, autogen, and perl.
  - test-suite.log now contains basic system information, and the
    console message about bug reporting on failure has a bit more detail.
  - When using the (default) "parallel" test driver, you can now omit the
    output of skipped tests from test-suite.log by defining the
    variable IGNORE_SKIPPED_LOGS to a non-empty value. (bug#71422)
- Drop patches now included in 1.17
  * tests-Fix-type-defaults-error-in-link_cond.patch
  * tests-avoid-implicit-function-declaration-in-depcomp.patch
  * tests-don-t-try-to-prevent-flex-from-including-unist.patch
  * tests-avoid-implicit-function-declarations.patch
- Drop patch automake-require_file.patch with different upstream fix
- Drop no longer necessary patch
  automake-1.13.4-fix-primary-prefix-invalid-couples-test.patch
- Ajust patches automake-suse-vendor.patch and
  0001-correct-parameter-parsing-in-test-driver-script.patch

OBS-URL: https://build.opensuse.org/package/show/devel:tools:building/automake?expand=0&rev=97
2024-07-15 09:38:38 +00:00

133 lines
4.0 KiB
RPMSpec

#
# spec file for package automake
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
# remove bogus Automake perl dependencies and provides
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Automake::
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Automake::
%define flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "testsuite"
%define nsuffix -testsuite
%else
%define nsuffix %{nil}
%endif
Name: automake%{nsuffix}
Version: 1.17
Release: 0
Summary: A Program for Automatically Generating GNU-Style Makefile.in Files
# docs ~> GFDL, sources ~> GPLv2+, mkinstalldirs ~> PD and install-sh ~> MIT
License: GFDL-1.3-or-later AND GPL-2.0-or-later AND SUSE-Public-Domain AND MIT
Group: Development/Tools/Building
URL: https://www.gnu.org/software/automake
Source0: https://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz
Source1: https://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz.sig
# taken from https://savannah.gnu.org/project/release-gpgkeys.php?group=automake&download=1
Source2: automake.keyring
Source3: automake-rpmlintrc
Patch5: 0001-correct-parameter-parsing-in-test-driver-script.patch
Patch100: automake-suse-vendor.patch
BuildRequires: autoconf >= 2.69
BuildRequires: bison
BuildRequires: gcc-c++
BuildRequires: gcc-fortran
BuildRequires: xz
BuildRequires: perl(Thread::Queue)
BuildRequires: perl(threads)
Requires: autoconf >= 2.69
Requires: perl
Requires(post): info
Requires(preun): info
BuildArch: noarch
%if "%{flavor}" == "testsuite"
BuildRequires: cscope
BuildRequires: dejagnu
BuildRequires: etags
BuildRequires: expect
BuildRequires: flex
BuildRequires: gettext-tools
BuildRequires: libtool
BuildRequires: makedepend
BuildRequires: makeinfo
BuildRequires: pkgconfig
BuildRequires: python3
BuildRequires: sharutils
BuildRequires: zip
Requires: expect
Requires: flex
Requires: libtool
%if 0%{?suse_version} >= 1500
BuildRequires: vala
BuildRequires: pkgconfig(gobject-2.0)
%endif
%endif
%description
Automake is a tool for automatically generating "Makefile.in" files
from "Makefile.am" files. "Makefile.am" is a series of "make" macro
definitions (with rules occasionally thrown in). The generated
"Makefile.in" files are compatible with the GNU Makefile standards.
%prep
%setup -q -n automake-%{version}
%autopatch -p1
%build
sh bootstrap
%configure --docdir=%{_docdir}/%{name}
%make_build #%%{?_smp_mflags}
%if "%{flavor}" == "testsuite"
%check
# Some architectures can't keep up the pace.
%ifnarch alpha %{arm}
%make_build check
%endif
%install
%else
%install
%make_install
mkdir %{buildroot}%{_sysconfdir}
echo %{_prefix}/local/share/aclocal >%{buildroot}%{_sysconfdir}/aclocal_dirlist
ln -s %{_sysconfdir}/aclocal_dirlist %{buildroot}%{_datadir}/aclocal/dirlist
install -m644 AUTHORS ChangeLog NEWS README THANKS %{buildroot}%{_docdir}/%{name}
# info's dir file is not auto ignored on some systems
rm -rf %{buildroot}%{_infodir}/dir
#name == automake
%endif
%post
%install_info --info-dir=%{_infodir} %{_infodir}/automake.info%{ext_info}
%preun
%install_info_delete --info-dir=%{_infodir} %{_infodir}/automake.info%{ext_info}
%if "%{flavor}" == ""
%files
%license COPYING
%doc %{_docdir}/%{name}
%{_bindir}/*
%{_infodir}/*%{ext_info}
%{_mandir}/man1/*
%{_datadir}/aclocal*
%{_datadir}/automake-*
%config %{_sysconfdir}/aclocal_dirlist
%endif
%changelog