SHA256
3
0
forked from pool/libffi
libffi/libffi.spec
Richard Biener 4c23af4e71 Accepting request 1159617 from home:Guillaume_G:branches:devel:libraries:c_c++
- Add patches to fix BTI on aarch64:
  * 830.patch
- Update to 3.4.6:
  * Fix long double regression on mips64 and alpha.
- Update to 3.4.5:
  * Add support for wasm32.
  * Add support for aarch64 branch target identification (bti).
  * Add support for ARCv3: ARC32 & ARC64.
  * Add support for HPPA64, and many HPPA fixes.
  * Add support for Haikuos on PowerPC.
  * Fixes for AIX, loongson, MIPS, power, sparc64, and x86 Darwin.
- Drop upstreamed patches:
  * 808.patch
  * 810.patch

OBS-URL: https://build.opensuse.org/request/show/1159617
OBS-URL: https://build.opensuse.org/package/show/devel:libraries:c_c++/libffi?expand=0&rev=34
2024-03-20 08:11:13 +00:00

102 lines
3.1 KiB
RPMSpec

#
# spec file for package libffi
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define libffi_sover 8
Name: libffi
Version: 3.4.6
Release: 0
Summary: Foreign Function Interface Library
License: MIT
Group: Development/Languages/C and C++
URL: https://sourceware.org/libffi/
Source: https://github.com/libffi/libffi/releases/download/v%{version}/libffi-%{version}.tar.gz
Source99: baselibs.conf
# Fix BTI for aarch64 with PR 830
Patch1: https://github.com/libffi/libffi/pull/830.patch
# for make check
BuildRequires: dejagnu
BuildRequires: expect
BuildRequires: gcc-c++
BuildRequires: makeinfo
BuildRequires: pkgconfig
%description
The libffi library provides a portable, high level programming
interface to various calling conventions. This allows a programmer to
call any function specified by a call interface description at run
time.
%package devel
Summary: Include files for development with libffi
Group: Development/Languages/C and C++
Requires: libffi%{libffi_sover} = %{version}
%description devel
The libffi library provides a portable, high level programming
interface to various calling conventions. This allows a programmer to
call any function specified by a call interface description at run
time.
%package -n libffi%{libffi_sover}
Summary: Foreign Function Interface Library
Group: System/Libraries
%description -n libffi%{libffi_sover}
The libffi library provides a portable, high level programming
interface to various calling conventions. This allows a programmer to
call any function specified by a call interface description at run
time.
%post -n libffi%{libffi_sover} -p /sbin/ldconfig
%postun -n libffi%{libffi_sover} -p /sbin/ldconfig
%prep
%autosetup -p1
%build
# https://github.com/libffi/libffi/pull/647
%configure --disable-exec-static-tramp
%make_build
%check
# do not disable "make check", FIX THE BUGS!
%make_build check
%install
%make_install
# do not package the static library
rm %{buildroot}%{_libdir}/libffi.a
rm %{buildroot}%{_libdir}/libffi.la
%files devel
%{_libdir}/libffi.so
%{_includedir}/ffi.h
%{_includedir}/ffitarget.h
%{_libdir}/pkgconfig/libffi.pc
%{_mandir}/man3/ffi.3%{?ext_man}
%{_mandir}/man3/ffi_call.3%{?ext_man}
%{_mandir}/man3/ffi_prep_cif.3%{?ext_man}
%{_mandir}/man3/ffi_prep_cif_var.3%{?ext_man}
%{_infodir}/libffi.info%{?ext_info}
%files -n libffi%{libffi_sover}
%license LICENSE
%{_libdir}/libffi.so.%{libffi_sover}*
%changelog