3
0
forked from pool/libgpg-error
libgpg-error/libgpg-error.spec
Pedro Monreal Gonzalez c4266f3b83 - Update to 1.50:
* New set of process spawn functions. [T6249]
  * Fixed return type for gpgrt_b64dec_proc and gpgrt_b64dec_finish
    to gpg_err_code_t.  This enum return type is in almost all cases
    compatible to the formerly used gpg_error_t (i.e. unsigned int).
  * Interface changes relative to the 1.49 release:
      gpgrt_process_t                     CHANGED (never used).
      gpgrt_spawn_actions_t               NEW type.
      gpgrt_process_requests              NEW enum.
      gpgrt_process_spawn                 NEW.
      gpgrt_process_terminate             NEW.
      gpgrt_process_get_streams           NEW.
      gpgrt_process_ctl                   NEW.
      gpgrt_process_wait                  NEW.
      gpgrt_process_release               NEW.
      gpgrt_spawn_actions_new             NEW.
      gpgrt_spawn_actions_release         NEW.
      gpgrt_spawn_actions_set_redirect    NEW.
      gpgrt_spawn_actions_set_environ     NEW (posix only).
      gpgrt_spawn_actions_set_inherit_fds NEW (posix only).
      gpgrt_spawn_actions_set_atfork      NEW (posix only).
      gpgrt_spawn_actions_set_envvars     NEW (w32 only).
      gpgrt_spawn_actions_set_inherit_handles NEW (w32 only).
      GPGRT_PROCESS_DETACHED              NEW.
      GPGRT_PROCESS_NO_CONSOLE            NEW.
      GPGRT_PROCESS_NO_EUID_CHECK         NEW.
      GPGRT_PROCESS_STDIN_PIPE            NEW.
      GPGRT_PROCESS_STDOUT_PIPE           NEW.
      GPGRT_PROCESS_STDERR_PIPE           NEW.
      GPGRT_PROCESS_STDINOUT_SOCKETPAIR   NEW.

OBS-URL: https://build.opensuse.org/package/show/Base:System/libgpg-error?expand=0&rev=108
2024-06-20 15:21:20 +00:00

115 lines
3.7 KiB
RPMSpec

#
# spec file for package libgpg-error
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: libgpg-error
Version: 1.50
Release: 0
Summary: Library That Defines Common Error Values for All GnuPG Components
License: GPL-2.0-or-later AND LGPL-2.1-or-later
Group: Development/Libraries/C and C++
URL: https://www.gnupg.org/software/libgpg-error/
Source0: https://gnupg.org/ftp/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
Source1: https://gnupg.org/ftp/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2.sig
# http://www.gnupg.org/signature_key.en.html
Source2: https://gnupg.org/signature_key.asc#/%{name}.keyring
Source3: baselibs.conf
#PATCH-FIX-OPENSUSE Do not pull revision info from GIT when autoconf is run
Patch0: libgpg-error-nobetasuffix.patch
BuildRequires: libtool
BuildRequires: pkgconfig
%description
This is a library that defines common error values for all GnuPG
components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
pinentry, SmartCard Daemon, and possibly more in the future.
%package -n libgpg-error0
Summary: Library That Defines Common Error Values for All GnuPG Components
License: GPL-2.0-or-later AND LGPL-2.1-or-later
Group: Development/Libraries/C and C++
Provides: libgpg-error = %{version}
Obsoletes: libgpg-error < %{version}
%description -n libgpg-error0
This is a library that defines common error values for all GnuPG
components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
pinentry, SmartCard Daemon, and possibly more in the future.
%package devel
Summary: Development package for libgpg-error
License: GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
Group: Development/Libraries/C and C++
Requires: glibc-devel
Requires: libgpg-error0 = %{version}
Requires(post): info
Requires(preun): info
%description devel
Files needed for software development using libgpg-error.
%prep
%autosetup -p1
autoreconf -fiv
%build
%configure --disable-static \
--enable-install-gpg-error-config
%make_build
%install
%make_install
rm %{buildroot}%{_libdir}/libgpg-error.la
# Drop the lisp stuff, it depends on ASDF and CFFI
# which needs to be packaged first
rm -r %{buildroot}%{_datadir}/common-lisp
%find_lang %{name}
%check
%make_build check
%post -n libgpg-error0 -p /sbin/ldconfig
%postun -n libgpg-error0 -p /sbin/ldconfig
%post devel
%install_info --info-dir=%{_infodir} %{_infodir}/gpgrt.info.gz
%preun devel
%install_info_delete --info-dir=%{_infodir} %{_infodir}/gpgrt.info.gz
%files -n libgpg-error0 -f %{name}.lang
%license COPYING.LIB COPYING
%doc README NEWS ChangeLog AUTHORS ABOUT-NLS
%{_libdir}/libgpg-error*.so.*
%files devel
%{_bindir}/*
%{_libdir}/libgpg-error*.so
%{_libdir}/pkgconfig/gpg-error.pc
%{_includedir}/*
%dir %{_datadir}/aclocal
%{_datadir}/aclocal/gpg-error.m4
%{_datadir}/aclocal/gpgrt.m4
%dir %{_datadir}/libgpg-error
%{_datadir}/libgpg-error/errorref.txt
%{_infodir}/gpgrt.info%{?ext_info}
%{_mandir}/man1/gpg-error-config.*
%{_mandir}/man1/gpgrt-config.*
%changelog