3
0
forked from pool/systemtap
systemtap/systemtap-headers.spec
Tony Jones 29b0745414 - Upgrade to version 5.1. See systemtap.changes for changelog
- Upgrade to version 5.1. See systemtap.changes for changelog 
- Upgrade to version 5.1. See systemtap.changes for changelog 
- Update to version 5.1
  Summary of changes:
  * SystemTap frontend (stap) changes
    - An experimental "--build-as=USER" flag to reduce privilege during
      script compilation, which is a security improvement effort.
    - New probe-points for userland hardware breakpoints/watchpoints
      targeting processes (PR31180):
        probe process.data(ADDRESS).write
        probe process.data(ADDRESS).rw
        probe process.data(ADDRESS).length(LEN).write
        probe process.data(ADDRESS).length(LEN).rw
    - Support for stap --remote=bpf.
    - Improved searching heuristics for probing symbol names with/without
      symbol-version suffixes and with/without weak names.
    - Made long-running debuginfod downloads more cleanly interruptible.
    - Improved stap-prep heuristics for finding debuginfo for "-rt"
      (real-time) kernels.
  
  * SystemTap backend changes
    - Dynamic namespace switching for processes targeted via "-x PID",
      allowing processes running within containers to be probed.
    - Improved message transport robustness for heavy traffic (individual
      messages spanning pages) and for short runs (avoiding loss of
      last-gasp messages).
    - Added MTAG macro on several internal memory allocation routines
      to improve leak warnings.  Corrected a bunch of leaks.
    - "stap -t" now reports module initialization timings too.
    - Ported runtime for GCC14 compatibility, with its more recent C
      dialect warnings.
    - Support for DW_OP_bra in DWARF location lists, which makes a few
      more $context variables accessible to systemtap.
  
  * SystemTap tapset changes
    - Portability fixes for more recent kernels, as always.
    - set_kernel_string* tapset functions improved range checking.
    - print_ubacktrace_fileline() works with PIE binaries.
    - Many portability improvements and some fixes in the testsuite.
    - Enhancements for the tcp, nfs, memory tapsets.
  Drop following patches (upstream):
    - bpf-translate.cxx-fix-build-against-upcoming-gcc14.patch
    - get-shm_flag-defines-from-the-appropriate-include-file-for-linux-6.8-kernel.patch
    - pr31288-build-with-gcc14-cont.patch
    - pr31288-build-with-gcc14.patch
    - pr31373-deal-with-the-removal-of-strlcpy-from-linux-6.8.patch
    - staprun-fix-build-against-upcoming-gcc14.patch
    - stapvirt.c-more-gcc-14-werror-calloc-transposed-args-compatibility.patch

OBS-URL: https://build.opensuse.org/package/show/devel:tools/systemtap?expand=0&rev=150
2024-06-17 23:02:55 +00:00

69 lines
2.4 KiB
RPMSpec

#
# spec file for package systemtap-headers
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
# Note: this separate package systemtap-headers exists so that ring0
# packages can make use of the SDT headers without pulling in all
# build requirements of the normal systemtap package. Normal use
# outside of BuildRequires in ring0 packages should use systemtap-sdt-devel
%if ! %{defined _rundir}
%define _rundir %{_localstatedir}/run
%endif
Name: systemtap-headers
Version: 5.1
Release: 0
Summary: SystemTap headers
License: GPL-2.0-or-later
Group: Development/Tools/Debuggers
URL: http://sourceware.org/systemtap/
Source0: https://sourceware.org/systemtap/ftp/releases/systemtap-%{version}.tar.gz
Source1: https://sourceware.org/systemtap/ftp/releases/systemtap-%{version}.tar.gz.asc
Source2: systemtap.keyring
Source3: README-BEFORE-ADDING-PATCHES
Source4: README-KEYRING
Source5: stap-server.conf
Patch1: systemtap-build-source-dir.patch
# sdt-devel provides the same header files as us, so we
# must conflict
Conflicts: systemtap-sdt-devel
%description
SystemTap is an instrumentation system for systems running Linux.
This package contains only the headers for static system probes and
exists only to limit build cycles. Normally you should install
systemtap-sdt-devel, which also contains these headers.
%prep
%setup -q -n systemtap-%{version}
%autopatch -p1
%build
# Our binutils always support '?' in the section characters on all
# architectures, no need for configure tests
sed -e 's/@support_section_question@/1/' < includes/sys/sdt-config.h.in > includes/sys/sdt-config.h
%install
mkdir -p %{buildroot}%{_includedir}/sys
cp -rp includes/sys/*.h %{buildroot}%{_includedir}/sys/
%files
%defattr(-,root,root)
%{_includedir}/sys/*.h
%changelog