1
0
python-pytest-httpserver/python-pytest-httpserver.spec
Dirk Mueller ea4888d48f - update to 1.1.0:
* Fixed an issue related to the leak of httpserver state
    between the tests when httpserver is destructed before the
    other fixtures. #352
  * Fix pytest-httpserver's own tests related to log querying. No
    functional changes in pytest-httpserver code itself. #345
  * New methods added to query for matching requests in the log.
  * Threading support to serve requests in parallel
    Optional[str], str], bool]`` will be accepted also.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:pytest/python-pytest-httpserver?expand=0&rev=28
2024-08-18 17:18:39 +00:00

69 lines
2.1 KiB
RPMSpec

#
# spec file for package python-pytest-httpserver
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-pytest-httpserver
Version: 1.1.0
Release: 0
Summary: A HTTP server for pytest
License: MIT
Group: Development/Languages/Python
URL: https://www.github.com/csernazs/pytest-httpserver
Source: https://files.pythonhosted.org/packages/source/p/pytest_httpserver/pytest_httpserver-%{version}.tar.gz
BuildRequires: %{python_module pip}
BuildRequires: %{python_module poetry-core}
BuildRequires: %{python_module toml >= 0.10}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-Werkzeug >= 2
Requires: python-pytest
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module Werkzeug >= 2}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module requests}
# /SECTION
%python_subpackages
%description
This library is for testing HTTP clients without contacting the real
HTTP server. In other words, it is a fake HTTP server which is
accessible via localhost can be started with the pre-defined expected
HTTP requests and their responses.
%prep
%setup -q -n pytest_httpserver-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/pytest_httpserver
%{python_sitelib}/pytest_httpserver-%{version}*-info
%changelog